Chrome video problem

Hi, I’ve been facing a problem for a few days now. After finishing all consume and produce operations on Chrome, I can’t get any video. When I check the track, I see that the muted value is true. When I look at webrtc-internals, I see the image below. As you can see, there are 3 parts in the inbound-rtp with the probator, and packets are coming to one of them. I couldn’t understand why the track is muted. The audio is working fine. Also, it’s working fine on Firefox. When I check the consumer stats, there are values in all of them. All consumers are in a resumed state and the producer scores are 10. Where should I look to detect the error? Thank you in advance.

Track can be muted because of many reasons like:

  • Producer is not producing correctly
  • Consumer is not being resumed correctly

You said that producer score is 10 so producer seems ok and you said consumer is in resumed state on client side, also check for consumer on server to see whether it is in resumed state or not.

Also check for errors in your server console may be you are sending data differently incase of chrome causing the issue.

Kindly share screenshot of the stats graphs of the producing track and consuming track to make sure data is being sent and received properly.

Also share the chrome version as well.

Thanks for reply.

How could the consumer be continued incorrectly? Below, you will see a screenshot of a part of the log that the server takes every 10 seconds for consumers. My chrome version is 109.0.5414.87

I am also sharing the inbound-rtp graph on chrome below. The first graph is the empty part, and the second part is the full part. I don’t know why there are multiple inbound-rtp information here.

All seems ok, having multiple inbout-rtp information is normal, I get 1 track per transport and there are 2 inbout-rtp logs for that 1 track in webrtc-internals.

Show me the tracks infor, stat graphs for tracks from webrtc-internals.

How do you know the track is in muted state? You console it? May be you are referring to wrong track. Show me the track info from console as well.

I read it somewhere that sometimes disabling ‘hardware acceleration’ fix this type of issue, not sure, you have to try.

I am getting the track muted information from the console. I have attached a screenshot below. There is no incoming or outgoing data in the track information and track graphs. I think if there were a problem with matching the wrong track information, I would also have to have a problem with Firefox. It seems like there may be a situation that requires a different setting in Chrome, such as a problem caused by simulcast settings. Also, I disabled hardware acceleration but have the same problem.

That can be the case, can you remove simulcast settings completely and try without it? Also check whether the peer connection is in connected state. If possible share some URL to have better look.

Hi again. I solved the problem. The problem was caused by incorrect handling of producers and consumers. I have no idea how it works on Firefox. That’s very strange. Thanks for the help.

Great, good to know. Understanding why it worked on firefox will be plus. May be you were producing from firefox and consuming on chrome and issue was only with consumer side or may be firefox consumed first so it worked for the first consumer but when chrome consumed second time then it didn’t work. Many reasons, anyways good to know that it is solved :+1: