Mediasoup on Safari 17 on Sonoma 14

After upgrade to Sonoma 14 with Safari 17, my application with MediaSoup stop working, the local camera apears, but there is no Publish or Consume video.

Firefox and Chrome on Sonoma 14 works fine.

I Tried the demo application, same problem, only local video is show, no remote, the browser type is show Safari 17, but no remote Image, only local, on both ends. No error is loged on the demo application.

I Tested on IOS 17 and IpadOS 17, and works fine, the problem is only on Safari 17 on Sonoma 14.

I have tested on Both X86 and M1 (Arm) and both have the same problem.

Any one else that have updated to Sonoma 14 have the same problem?


But you are not even providing any demo app log.

In the demo APP on mediasoup no error in show, on my application only show error in produce and error on consume.

If there is any other way to verbose the demo APP, i´m glade to help.

Since the upgrade came outro on 27 of September, 10 days ago, I´m trying to confirm that the error exist in those plataforms.

Do you mean you client side app or your server side app? And which errors (because that’s obviously relevant)?

I just tried my app and the demo app as well on sonoma 14, safari 17, everything works fine for me, produce, consume all works.

In my Aplications, server Side I don’t see any errors.

Client side I recive “falied Producer”

I try to conect again, It apers that on server side all its OK, but on the client I got falied Producer.

As apers I can´t consume because I can´t procuder, I think.

You are on remote machine connecting through VNC, so make sure the administrator has not restricted anything that is safari specific

I found the problem, after the upgrade both the Wireless and Wire network where activate, before upgrade only the wire connection was activeted, the wirelles was disabled.

As both Wire and Wirelles shares the same IP range, safari can´t connect.