Mediasoup worker default make failed

Running make under worker dir failed with error: ERROR: Subproject exists but has no file

OS: Ubuntu x86
Repo: mediasoup v3 latest ( 8c08445).

The same error occurs trying to run cargo build under rust dir.

Apparently something went wrong before and now you have inconsistent state.
Try to remove everything from worker/subprojects except packagefiles and *.wrap files.

Would be helpful if you can tell a bit more how you got there though. It works fine on my machine and in CI on 3 major platforms.

Yea, I tried again after deleting those generated dirs and it works now. Thanks.

Awesome! Let me know if you manage to reproduce it again, I’d be curious to see logs when that happens so we can prevent it from happening again.

Oh, just missed your reply! I think it’s the network problem, some logs appeared showing can't not resolve host xxx if I remember right, so the meson build failed. Perhaps that’s what you call inconsistent state.

Thanks, I’ll try to reproduce that and report to Meson folks, looks like something they would want to fix

Just another thing, I’m trying to run multiopus example, everything is ok except no audio to listen to (with maximum volume).

Environment: Ubuntu server x86

Running with paired frontend app. Sending data with docker run --rm -it --net=host restreamio/gstreamer:latest-prod-dbg with instruction in server side log:

rtpbin name=rtpbin \
  souphttpsrc location= ! \
  queue ! \
  decodebin ! \
  audioresample ! \
  audioconvert ! \
  opusenc inband-fec=true ! \
  queue ! \
  clocksync ! \
  rtpopuspay pt=100 ssrc=1111 ! \
  rtpbin.send_rtp_sink_0 \
  rtpbin.send_rtp_src_0 ! udpsink host= port=54869 sync=false async=false \
  rtpbin.send_rtcp_src_0 ! udpsink host= port=19360 sync=false async=false

Besides, there’s no incoming data in chrome://webrtc-internals/.

One thread - one issue

Yea, I crated a new thread.

I ran into this problem as well. Deleting the files helped. I have a note to check the build/files if this happens again.

I just reported the issue upstream, you can subscribe there for updates: Make Meson recover from bad download · Issue #9688 · mesonbuild/meson · GitHub