No streams between clients while google meet is fine

Our app is classic mediasoup server (no piping) with several clients connected to it.
Everything mostly works great, but sometimes we have this problem when no actual streams are coming to either clients or only to one.

It is very rare, but looks like it happens only with some very particular clients. For example it is reproducible 95% when one of my colleague is connected. But sometimes even with this colleague everything is fine (in fact it happened only once, but it did!). And when I say it worked I mean it does not work like 10 times without any changes, we just hit refresh, and then it suddenly works on another refresh and it does not on the next one.

At first I thought it is some problem with our app, but then I tried official mediasoup demo and the result was the same.

Then I thought may be it is one of those cases when we need turn servers, but we do send ice servers with every connection (we use

Then I thought may be it is one of those cases when webrtc cannot connect at all, but google meet works fine with the same client. Slack video/audio call also works fine.

I tried to compare chrome://webrtc-internal of unsuccessful session with successful of google meet, but it looks fine on the surface.

I would appreciate any ideas where to look for problem, where to even start looking.

Thank you!