Troubles using ngrok


I’ve created a simple mediasoup app based on this sample app:

My application works well when running the server in the console and connecting from my browser. I then tried to use ngrok to test it better. When I connect to the link created by ngrok from my computer the app works fine, but when I try to use it from another computer I cannot succeed to connect the transport. The transport connection state goes from “connecting” to “disconnected” (on the client side log).

Here is my config file:

const os = require('os');

module.exports = {
  listenIp: '',
  listenPort: 3000,
  sslCrt: `${__dirname}/certs/crt.crt`,
  sslKey: `${__dirname}/certs/key.key`,
  mediasoup: {
	numWorkers : Object.keys(os.cpus()).length,  
    // Worker settings
    worker: {
      rtcMinPort: 10000,
      rtcMaxPort: 10100,
      logLevel: 'warn',
      logTags: [
    // Router settings
    router: {
    // WebRtcTransport settings
    webRtcTransport: {
      listenIps: [
          ip: '192.168.***.***',
          announcedIp: undefined
      maxIncomingBitrate: 1500000,
      initialAvailableOutgoingBitrate: 1000000,

I tried with my public IP address or the IP address corresponding to the ngrok generated link as the webRtcTransport announcedIp, but in both of those cases the app didn’t work neither from another PC nor from mine.

If someone succeeded to use mediasoup with ngrok or another tunneling software and see where is my problem please let me now!

This is not about mediasoup-client but about mediasoup-demo.

I was indeed hesitating between both folders. Thanks for changing it