Cant yarn install anymore windows 10

I’ve been using mediasoup for a while now without issue, but recently I haven’t been able to yarn install it. Mediasoup version 3.11.12, ive tried a few other versions and all give the same error.

It looks like its saying python or pip is unavailable but i dont know what has changed, they still seem available to me.

That folder, C:\Users.…\AppData\Local\Microsoft\WindowsApps, is very special. The user has no read access to anything there, even with elevated privileges. He can only execute programs from that folder. But, GNU make always tries to open and read an executable before running it (checks if by chance it contains a shell script instead of a binary program). Hence the error: “Cannot open”.

So, uninstall currently installed Python. Then go to system Settings → Apps & features → App execution aliases, disable App Installer python.exe and python3.exe. And then install Python from Download Python |

1 Like

It worked! Thank you so much :pray::pray::pray: Really appreciate the explanation.