Installation Problem Windows: PostInstall script

Having trouble installing Mediasoup on windows. I get a postinstall script error when running ‘npm install mediasoup@3’. I am not trying to run the example project (but even when i tried, i got the same error). Python 2.7 installed. Environment variables set per official instructions. Not 100% sure I did it correctly but MSBuild is not in a /bin/ folder or even close to the example path given in the instructions.

Install “Desktop development with C++” from visual studio installer. It should solve your problem.
Also try with visual studio 2017. not sure that 2019 is supported.

Can you please verify if mediasoup website says about that requirement in the Installation section of mediasoup (for Windows)? If not, please open an issue in mediasoup-website project in GitHub.

Regarding VS 2019 there are two ongoing issues in mediasoup GitHub tracker.

Instructions state that Windows users are required to: A) Install a later version of node - Running v11.1.0.

B) Install Python 2. - Running v2.7.10

C) Make sure there is a PATH to folder containing MSBuild.exe --(C:\Windows\Microsoft.NET\Framework64\v4.0.30319)

D) Create environment variable for GYP_MSVS_VERSION with the value field set to the year that corresponds to the version of Visual Studio installed. - Set to “2017” (no quotes),

Installed Desktop development with C++ but that did not solve the problem, same error. Installed Visual Studios 2017, same error. There is a folder called “MSBuild” inside C:\Windows\Microsoft.NET\Framework64\v4.0.30319 but it contains two files: Microsoft.Build.Commontypes.xsd and Microsoft.Build.Core.xsd, not the MSBuild.exe.


Ok so one issue was that I had MSBuild as a USER VARIABLE. It has to be SYSTEM VARIABLE. Now that fixed, I’m getting a new error:

“A:\Documents\Projects\node_modules\mediasoup\worker\mediasoup-worker.sln” (default target) (1) ->
“A:\Documents\Projects\node_modules\mediasoup\worker\deps\libwebrtc\deps\abseil-cpp\abseil.vcxproj” (default target) (2
) ->
A:\Documents\Projects\node_modules\mediasoup\worker\deps\libwebrtc\deps\abseil-cpp\abseil.vcxproj(21,3): error MSB401
9: The imported project “A:\Microsoft.Cpp.Default.props” was not found. Confirm that the path in the declarati
on is correct, and that the file exists on disk.

There are 8 of these errors.

I set VCTarget to C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VC\VCTargets, all those dependencies are there I can see them but this error persists.

I suspect there is an issue between VS Community version and Standard addition that needs to be addressed but I don’t have Standard to run any tests. So many hours fighting this… Can MediaSoup be run on a Raspberry Pi running Ubantu?

If you can summarize the specific error please report this in mediasoup GitHub. We, mediasoup authors, do not use Windows but can try to manage the problem.

Probably.

yeah,vs 2017 save my life