Mediasoup installation error in Windows10

I’ve followed the installation advice so far though, keep confronting errors.

Things I tried so far are:

  1. re-install PIP, GNU make and gcc
  2. used different versions of Node.js(over v12)
  3. installed visual studio and software development kit for C++

The error log is below:

Give me advice please

What does make -v show?

This is the result of make -v command

GNU Make 4.3
Built for Windows32
Copyright (C) 1988-2020 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law

Well, your log shows that there is something strange with the make: it did not even try to do anything. Consider installing a make from MSYS as per instructions. Make sure that it before other make in the PATH when mediasoup installation is running.

1 Like

It was the cause installing make with chocolatey.
So I reinstalled make and msys with MinGW and overwrote the system environment path over chocolatey’s one then it worked.

Thanks a lot for you and hope this case also helped others.