mediasoup on Heroku


I am trying to deploy a mediasoup server to Heroku.
The code works fine on my local machine but when I run it on Heroku I get a “wrong settings” error (see below).

The message does not offer too much information, any idea how to debug this?

TypeError: wrong settings
at ChildProcess. (/app/node_modules/mediasoup/lib/Worker.js:121:43)
at ChildProcess.emit (events.js:311:20)
at Process.ChildProcess._handle.onexit (internal/child_process.js:275:12)

There is a Debugging section in mediasoup website. No idea which settings you are passing to the Worker, no idea whether you are using the mediasoup-demo project or what.

Ok, thanks for the feedback. I’ll try to enable more logs and see if it gives me more information.

@yonatann Did you ever get this working on Heroku?

@wvb1, no there is a problem with the port forwarding.
You have to be able to control it.

I ended up using digital ocean which worked great.

Thanks! saved me a lot of time not trying it!

@wvb1 you’re welcome, glad I could help

Which service did u use in Digital Ocean? App Platform, Droplets or Kubernetes?

I used a simple droplet