Mediasoup publishing probator packets on rtp port of plain transport

We have an issue where video media is muxed with probator media on the same port when sending to the recording component (This is our component that listens to the plain transport created in mediasoup to listen to the incoming media from browser and publish it on a port for recording). Is there a way to disable sending probator media to recording client.
For example our H264 media payload is 125 and probator payload is 127, both are sent to recording client. We just want to sent PT 125.

Your client should ignore probation packets (those with payload type 127 and ssrc 1234).

If that’s not possible, then don’t lie mediasoup in the rtpCapabilities you are passing to it when consuming the producer, meaning that do not tell mediasoup that your client supports transport-wide-sew RTP extension header and transport-cc RTCP feedback.

So is there a way to disable it on the router itself. Mediasoup router automatically adds this to the router rtpCapabilities although I am not including it in my codecs when creating the worker.

I removed both the things you mentioned before calling produce, but still seeing 127 PT data.

if (produceParameters && produceParameters.rtpParameters) {
			produceParameters.rtpParameters.codecs.forEach(codec => {
				codec.rtcpFeedback = codec.rtcpFeedback.filter(r => r.type !== 'transport-cc');				
			});
			produceParameters.rtpParameters.headerExtensions = produceParameters.rtpParameters.headerExtensions.filter(h => !h.uri.includes('transport-wide-cc-extensions'));
		}

Please focus on what I said. It was accurate.

I mentioned rtpCapabilities when you consume() the producer, right? You are removing stuff from producer rtpParameters instead. No idea why but that’s far from what I said.

my bad. I probably read it wrong. I did it on consumer and still see some initial packets with 127 type and then it is coming in as 125. Is there a way to stop it altogether.

Hi… I am able to get the stream without the 127 PT type but we are still seeing some initial 127 packets before it stops. Anything we can do to stop it completely.