Simulcast options does not take effect

I’m testing Simulcast capabilities with MediaSoup and it seems like the maxBitrate param does not take any effect. Hence, I’d like to clarify a few things:

  1. Why the maxBitrate and other options (scalabilityMode) does not take effect? Am I missing something?
  2. Despite I send 3 streams (3 records in encodings) on track producing, only 2 are recognized by producer stats on the server. Why? However, on the receiving side, I get ‘S1T3’ as expected.
  3. I noticed that once I have Simulcast enabled, the data being sent is always around 100KB/sec. Is this something we can control with MediaSoup client? If Simulcast is disabled it usually sticks to ~200KB/sec., which produces a better video quality.

Thanks in advance.

Because that depends on the browser and its support of modern encodings based simulcast, which is not enabled by default (due to some ongoing issues) in the handler of Chrome. If you want to try it, use Firefox or use Chrome by passing the “Chrome74” in the new Device() options.

I’m afraid this cannot be a general WebRTC discussion forum. This is common in any WebRTC application. Whether the browser decides to create 2 or 3 simulcast streams depend not just on given settings but also on the video track resolution, CPU usage, network conditions, etc.

The scalabilityMode setting is just informative (it tells you the maximum number of streams and layers the producer may generate).

1 Like