An error while testing at localhost

I’m getting an error in this :

Please do help.
Am on windows using wsl2
Source code is present here : miroslavpejic85/mirotalksfu: Open Source WebRTC with integrated SFU. Video calls, messaging, screen sharing, recording and more. (

Try removing node_modules and trying again. The error doens’t make much sense to me and I don’t understand why it tries to use node from node_modules.

Thanks for replying…
It’s the same error again…

There must be something broken with the environment you have, I have no idea what is going on, but it is not mediasoup’s fault.

Ow, but actually it works great with Linux and MAC only a prob with WSL2…
Some config problem… ?

Ok, which kind of “config problem” do you suggest?

Like… Am missing some libs in my WSL2 that it ain’t running?

As far as you satisfy mediasoup installation requirements for Windows (described in the website) no extra libs should be required.

WSL2 is a Linux environment though

1 Like

I use mediasoup with wsl2 with no problems … maybe try to sudo npm install ?

Had done it long back… Before runnin this…

I would suggest to never use sudo with npm, this is almost always a bad idea.

Just got this error on powershell windows… if I run this command…

Please read mediasoup :: Installation for Windows requirements

Okay sure!

I’ve got another error after checking the requirements and tryin it again, I use WSL2 on windows 11 :

WSL2 has nothing to do with Windows, it is a regular Linux environment (Ubuntu by default AFAIK).

Do you even have node available as a command?


Then as I mentioned before you need to figure out what is the node executable in the error you’re getting. It has nothing to do with mediasoup, so can’t help you with that.

But where is the executable located? Take a look at the script the shell is trying to execute (/mnt/c/Users/…/bin/node). I believe you’ll find a text file with the fisrt word “This” there. :slight_smile: