demo + chrome: possible small bug

your demo :
In chrome (81) when you disable uncheck your micro, windows and chrome still shows it uses the micro

Whereas in firefox, micro is free and windows sees it as not used by the browser.

People who don’t want to show their cam and micro any more and just want to text chat have the impression that the demo still has access to audio.

Is there a way to change that ?


PS. IMHO was not the case with v2 (but not 100% sure)

Of course it was the same for v2. When you click on the mute icon you don’t stop the mic track but just set track.enabled=false, which stops sending audio RTP but the microphone device is still capturing.

Close the mic Producer if you want to stop the mic track so no more “active mic” icon in Chrome tab.