libmediasoupclient fails on aws ec2 with no audio device

We are trying to implement a re-encoder, as suggested in the scaling documentation (

We have started with compiling libmediasoupclient and walking through the mediasoup-broadcaster-demo example (

We have an issue on the aws server, as it doesn’t have any audio device, it fails when loading the device, with the following error:

Check failed: 0 == adm->Init() (0 vs. -1) # Failed to initialize the ADM.Aborted

We also tried compiling with the webrtc flag (webrtc.gni)

rtc_use_dummy_audio_file_devices = true

but than trying to call device load, ends up in a segmentation fault.

Anyone had a success in compiling this project with no audio device?
Eventually, we do need to pass the audio of the broadcaster.


Unfortunately I experimented the same issue trying to run it on a Linux server. It works in OSX but I didn’t make the dummy audio work in Linux (same issue). I “think” pulseaudio properly configured is needed and so on, but no idea honestly.

Thanks @ibc
So, what could be an option for installing such a re-encoder, if we need it on the cloud?

I don’t know, sorry. This is a pure libwebrtc related issue so you may ask in other forums.


At the time we had an echoer demo with libmediasoupclient that would simply receive audio/video from mediasoup and send it back. It worked on linux server without any audio/video card. In order to do that we had to create a dummy AudioDeviceModule subclass.

The implementation is outdated and not maintained. It follows the same design and architecture as current “broadcaster” does. I can’t really say which libwebrtc version it was built against with, but for sure won’t work with newer ones.

I can share such repo if you want.

Indeed this picture was taken using such project.

@eyals Did you manage to fix the issue with “# Failed to initialize the ADM.Aborted” I tried build the demo and got the same error. I do have audio card and and tried multiple modules, but without luck. I ended up removing the check from libwebrtc webrtc-checkout/src/media/engine/, but and disabled audio from the demo, but I kept getting segmentation fault. I think the demo has old code and not maintained.

If you managed to build it, please let me know.