Mediasoup 3.3.2 build failed on Alpine

Hello everyone. Just tried to update server build with new version of mediasoup.
Using alpine based dockerfile to build:

FROM node:lts-alpine


COPY package.json .npmrc $WORKDIR/
RUN set -ex; \
  apk add --no-cache --virtual .build-deps \
    build-base \
    linux-headers \
    python2 \
  ; \
  npm install; \
  apk del .build-deps;


Nothing happens after this screen

It stay unchanged for 40 minutes and wont to be built.
Sometimes build fails with npm error

command terminated with exit code 137

What was changed in build process, 3.2.x version is building normal

Sorry, impossible to help with such a problem description.

Build process is frozen, nothing happens for 40 minutes and more, tried to build on remote server, and on local docker environment, no results. Will try to collect some debug info.

As you may anticipate, this is not a bug in mediasoup but “whatever” in your Docker stuff. We have definitely built mediasoup on Docker thousands of times.

Sure. It consumes toooo much resources for build in alpine, docker kills the process itself.

I’m afraid you should tune your container to build mediasoup. We cannot reduce the build process more than it is.