Opera browser issue

I try to use MS demo https://v3demo.mediasoup.org/
on Opera (latest v69.0.3686.77) and I cannot watch any cam (no JS errors)

I tried both with and without VPN. The playback is always black and no sound (I just can see my won cam)

Stats all show : 0
Any idea ?

I recommend doing window.localStorage.setItem(“debug”, “*”) and refresh the page. After that you’ll be seeing console logs from different libraries and you can self-service the issue.

I did that and here is the result:


It worked on MS2 (but the mediasoup2 demo is closed now)

I tried on different PCs and and I confirm that MS3 does not work on Opera

Just tested the mediasop-demo in Opera 69.0.3686.77 in OSX Mojave. It works perfectly.

I am having the same issue with Opera version 69.0.3686.77 and prior versions as well in Windows 10. The official MS3 demo does not seem to play or publish at all. No errors are visible in the console. It seems more like an SSL / connection related issue because both playing and publishing fails. Tried with VPN mode enabled and disabled same result.

I also have the same problem in the MS3 application I am developing. Can anyone please share a link to an MS3 application that works in Opera on Windows 10?

Sure, here it is: https://v3demo.mediasoup.org/

Jokes aside, works fine for me. I would check the camera and microphone settings in your opera, maybe Windows is blocking the camera access or something along those lines. That usually leads to WebRTC applications not working without any visible error because the browsers are not very responsive in those cases. Checking the codecs could also help, maybe Opera has e.g. issues with H264.

Tested with 2 Macs: works fine (except when VPN is on)
Tested with 2 win10: both failed.
Of course access to micro and cam are enabled

What about with Opera VPN enabled, ceggert87? For me with VPN enabled, it never works, but MS2 still works fine with VPN enabled. I even tried streaming from Chrome and watching in Opera, still no good.

No, with VPN it doesn’t work. It looks to me like your connectivity is limited using that feature (check test.webrtc.org -> only relay/tcp works).

If you want it working with restricted networks, I suggest you host a TURN server or use a service (e.g. Twilio) that offers them and configure that into your mediasoup. That should solve the issue.

@yarekc it might also be the Windows 10 Firewall interfering, please test the test.webrtc.org site as well. As far as I know there are no WebRTC internals in Opera to check stuff there unfortunately…

@ ceggert87 I have an MS2 application that works 100% of the time out of the box in Opera with VPN enabled, but the same application using MS3 fails. I have no firewalls enabled at all.

I thought MS3 was suppose to make it easier to use VPNs, not harder (In mediasoup v2 just a static IPv4 and IPv6 pair can be assigned to all transports. In v3, instead, each transport can be provided with multiple and different IPv4 and/or IPv6 addresses. This enables scenarios in which media is conveyed through public and private network interfaces.)

Sorry, but I don’t see how anyone is supposed to help if the only response to everything is “But it works in v2!” without trying or analyzing anything. This is most likely an issue on the WebRTC level (hence the logs look fine), and this can have multiple of reasons. The IP-address provided in mediasoup should be irrelevant if it works without VPN as the server has only one IP anyway. There could be differences in the port range or in your TCP settings having an influence though, for instance. I had cases where WebRTC solutions were not working just because I was allowing UDP -> the clients thought they can establish connections through UDP and ditched TCP in favor of it, but were actually unable to do that, for example. You could try testing your working vs. non-working version in another browser and analyze the webrtc-internals, maybe there is some major difference in what candidate pairs it tries that gives you the important clue.

1 Like

This is what the doc says, yes. You must diagnose ((by checking ICE logs in client and server) why your setup in v3 does not work.

Thanks for your advice guys, but I was hoping that you would at least make the official MS3 demo work in Opera when VPN mode is enabled which would demonstrate that the most basic setup of the server works. If the official demo does not work, I think the odds of me making my application work are 0% unless I was one of you guys. Just trying to help the community in the only way I can contribute at this time.

I am 1000% sure that the MS2 official server demo also works with Opera VPN enabled but the MS3 demo does not. Wouldn’t you want the MS3 demo to work?

I’m not paid for making a demo app work with Opera. If you figure out the issue please send a PR. I don’t want to work more.