The demo can't work with 3.10.x !!!


The demo can’t work with mediasoup 3.10.x.

  1. Open two web browser and put “https://x.x.x.x:3000?romeId=xxx
    2.It works the first time.(You can see each other in video)
  2. Close these two browser and re-open two web browser.(try again)
  3. it can’t work.(You can’t see each other in video. It seems no video stream was send to mediasoup server. No error log in the mediasoup server console)

Try ending the call before closing the browser, it should work in my opinion. This is demo app and may be lacking some re-connectivity thing if you rejoin without ending.

I tried another roomId when I re-open browser . It means a new conversation. But the video is not work.

Can you confirm if the thing work when you properly end the call instead of just leaving randomly?

Have you setup this on you local? If yes are there any errors in node server?

You mentioned typically about 3.10 version does this work with 3.9?

This issue is only happen in 3.10.x with MEDIASOUP_USE_WEBRTC=ture.

It works fine in 3.9.x or 3.8.x version with the same mediasoup-demo project.(Just close the web browser inderectly) .

I will try end call and see if it works fine.

It seems the issue caused by the 3.10 new feather of MEDIASOUP_USE_WEBRTC=ture

I don’t think there is any thing like MEDIASOUP_USE_WEBRTC in mediasoup, this seems to be your project specific.

The “MEDIASOUP_USE_WEBRTC” is the param for the new feather:


  • WebRtcServer: A new class that brings to WebRtcTransports the ability to listen on a single UDP/TCP port (PR #834).

I think this constant is the one which you use internally in your all to enable new webrtc server approach. This doesn’t belong to mediasoup.

yes, this MEDIASOUP_USE_WEBRTC is defined in mediasoup-demo project.

mediasoup-demo doesn’t work with mediasoup 3.10.x

Have you checked with ending the call properly?

Some issue related to 3.10.x was solved here as well, he updated the mediasoup-client version:

You asked this couple of months ago as well :smile:

don’t think its the webrtcserver issue, i got it fully working but using rust though